Bug Tracker

Opened 11 years ago

Closed 9 years ago

#3698 closed enhancement (fixed)

Selector enhancement

Reported by: shazam Owned by:
Priority: minor Milestone: 1.3
Component: selector Version: 1.2.6
Keywords: ~= operator regexp Cc: shazam
Blocked by: Blocking:

Description

Enhance ~= operator (which is supported but not documented and works exactly like *= operator) so that it can handle regular expressions.

It works fine, the diff is attached

Attachments (1)

selector.diff (1.2 KB) - added by shazam 11 years ago.
diff based on rev 5962

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by shazam

Attachment: selector.diff added

diff based on rev 5962

comment:1 Changed 11 years ago by shazam

Needs type change from bug to enhancement... sorry

comment:2 Changed 11 years ago by shazam

...It works fine as long as you don't use '/' caracter in pattern...

comment:3 Changed 11 years ago by cloudream

By designed.

And won't fixes in 1.3

comment:4 Changed 11 years ago by shazam

Do you mean "by design"? I don't think so! Or, please, tell me how to do.

Being able to match attributes values with a regular expression might be very useful in XML parsing.

I think you misunderstood my post.

comment:5 Changed 11 years ago by flesler

Cc: shazam added

I think this was requested in the past at jquery-dev. Can you ask for feedback at jQuery's google group ?

Then we'll see. You can link to this ticket if you will.

comment:6 Changed 11 years ago by kswedberg

Type: bugenhancement

comment:7 Changed 11 years ago by shazam

This ticket might now be closed as it targetted jQuery1.2.6.

A new ticket with a new diff is opened for jQuery1.3.1 http://dev.jquery.com/ticket/3951

comment:8 Changed 9 years ago by dmethvin

Resolution: fixed
Status: newclosed

The word-match feature was added/fixed in 1.3. The RegExp feature is left for enhancement #3951.

Note: See TracTickets for help on using tickets.