Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#368 closed bug (wontfix)

attribute selector not working in IE6 in jQuery 1.0.3

Reported by: tdeater@… Owned by:
Priority: major Milestone:
Component: core Version:
Keywords: Cc:
Blocked by: Blocking:

Description

Using this selector to find null links in my #nav container:

$("#nav a[@href='#']")

This works fine for all tested browsers using the 2006-08-31 (rev 249) release of jQuery.

In the 1.0.3 release however, IE selects zero elements. Firefox 1.5 works correctly still.

Change History (1)

comment:1 Changed 14 years ago by brandon

Resolution: wontfix
Status: newclosed

This is caused by IE messing with the attribute value when using getAttribute on the a tag's href attribute. Instead please use:

$("#nav a[@href$='#'");

See http://jquery.com/docs/Base/Expression/CSS/ for more info on this selector.

Note: See TracTickets for help on using tickets.