Bug Tracker

Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#3646 closed bug (duplicate)

animate() with empty params object == nothing

Reported by: strager Owned by: flesler
Priority: major Milestone: 1.3
Component: effects Version: 1.2.6
Keywords: animate Cc: strager
Blocked by: Blocking:

Description

Calling animate as such:

myJQueryObject.animate({}, 2000);

Freezes the animation queue. Next animation doesn't start after 2s; everything just seems to stop.

(I was doing this to have a pause in between animations. Maybe there's a better way to do this?)

Attachments (1)

test-3646..html (489 bytes) - added by dmethvin 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by flesler

Cc: strager added
Owner: set to flesler
Status: newassigned

You could use a fake attribute, or an irrelevant one. I'll check this out asap.

comment:2 Changed 11 years ago by strager

Yeah, I used {opacity: '+=0'} as a temporary fix and it worked fine (didn't change opacity).

Changed 9 years ago by dmethvin

Attachment: test-3646..html added

comment:3 Changed 9 years ago by dmethvin

I think we just need to move the test for an empty object inside the each/queue and call the completion function.

comment:4 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: assignedclosed

comment:5 Changed 8 years ago by dmethvin

Duplicate of #5459.

Note: See TracTickets for help on using tickets.