Bug Tracker

Opened 12 years ago

Closed 12 years ago

#3617 closed bug (invalid)

$(window).load() event waits CSS file media="print" indefinitely

Reported by: JuniorZ Owned by: brandon
Priority: major Milestone: 1.3
Component: event Version: 1.2.6
Keywords: opera, media, print, document, ready Cc: JuniorZ
Blocked by: Blocking:

Description

The problems seems to be related to how Opera deals external CSS files loading.

If you have a CSS file, with the media="print", the event never happens.

I've tested in Opera/9.62 (Windows NT 5.1; U; pt-BR) Presto/2.1.1 and had the problem. Firefox, Internet Explorer and Safari (Google Chrome) are OK.

Attachments (1)

test.html (673 bytes) - added by JuniorZ 12 years ago.
Example used

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by JuniorZ

Attachment: test.html added

Example used

comment:1 Changed 12 years ago by flesler

Cc: JuniorZ added
Keywords: opera media print document ready added
Priority: criticalmajor
Resolution: invalid
Status: newclosed

The problem is that you bind the onload handler inside the document.ready.

That assumes that the latter will happen first.

You need to do the $(window).load() outside document.ready.

Note that rhe ready event is to be bound on the document, not the window, still, that wouldn't cause any bug, just mentioning.

Note: See TracTickets for help on using tickets.