Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3600 closed bug (invalid)

DatePicker Bug

Reported by: Ven Owned by: joern
Priority: critical Milestone:
Component: web Version: 1.2.6
Keywords: Date Picker Bug Cc: venh.123@…
Blocked by: Blocking:

Description

The Date Picker has a Bug. Only for the Month of November 2008, there are duplicate dates shown in the DatePicker. This is happening for 11-02-2008. Please take a look at the date picker given in the demonstration of your site itself. The bug is shown even there. Please let me know the solution for this.

Attachments (1)

DatePickerBug.JPG (14.1 KB) - added by Ven 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Ven

Attachment: DatePickerBug.JPG added

comment:1 Changed 11 years ago by pegas123@…

I can confirm. The 11/2/08 is duplicate. Other months/years seem to be O.K. I am using jquery-ui-personalized-1.5.2 downloaded today. Happens in IE, FireFox and Chrome (so it is not JavaScript interpreter-related nor add-in influenced). Shoot me email if you can use my help with debugging/testing.

comment:2 Changed 11 years ago by pegas123@…

I can guess what it is. Look at the _generateDatepicker function. The last row of the dow loop () is supposed to increment the actual day:

printDate.setUTCDate(printDate.getUTCDate() + 1);

When you execute it with printDate = 11/2/2008 00:00 EDT you get 11/2/2008 23:00 EDT. Is't that caused by the las day of the summer time?

Not sure what the best fix would be -- reliably and efficiently adding one day (not just 24 hours)?

comment:3 Changed 11 years ago by flesler

Resolution: invalid
Status: newclosed

Just check older tickets, don't go creating tickets just like that, please.

comment:4 Changed 8 years ago by anonymous

Where can we have the good explanation for this problem ?

I'm using an old version of jquery-ui (1.6) and i cannot upgrade the version to 1.7 (otherwise everything is broken) i need to patch the datepicker 1.6 and to fix the bug, how can i do ?

Note: See TracTickets for help on using tickets.