Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3579 closed bug (invalid)

jQuery UI: Calendar date repeats in November 2008

Reported by: gcp0703 Owned by:
Priority: critical Milestone: 1.3
Component: plugin Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

When the calendar pops up, November 2 appears twice on the calendar shifting all dates up by one day.

For example, november 3 should be Monday. The dates shown instead are: Sat Nov 1 Sun Nov 2 Mon Nov 2 Tue Nov 3

Attachments (1)

calendar.tiff (44.0 KB) - added by gcp0703 11 years ago.
TIFF screenshot of the problem

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by gcp0703

Attachment: calendar.tiff added

TIFF screenshot of the problem

comment:1 Changed 11 years ago by jehinkle

The problem is daylight savings time. The Date object sets the year,month and day, but with no time specified defaults to midnight. So when the time increments by 1 day, and then daylight savings sets it back 1 hour, you get two November 2 on the calendar. Include a time greater than 1 when the date object is created and problem is solved.

Change line 1272 in ui.datepicker.js or line 5801 in jquery.ui.all.js from:

var printDate = new Date(drawYear, drawMonth, 1 - leadDays);

to:

var printDate = new Date(drawYear, drawMonth, 1 - leadDays,12);

comment:2 Changed 11 years ago by flesler

Resolution: invalid
Status: newclosed

This belongs to the UI Bug Tracker.

Note: See TracTickets for help on using tickets.