Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3574 closed bug (invalid)

Datepicker UI has two days with the same number for November.

Reported by: jeberly Owned by: flesler
Priority: major Milestone: 1.3
Component: unfiled Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

Go to datepicker for 2008 and notice two Nov 2nd's.

Change History (3)

comment:1 Changed 11 years ago by hunterheitzm

also displays numbers incorrectly for November 2007 if you go a year back.

comment:2 Changed 11 years ago by jehinkle

The problem is daylight savings time. The Date object on line 172 sets the year,month and day, but with no time specified defaults to midnight. So when the time increments by 1 day, and then daylight savings sets it back 1 hour, you get two November 2 on the calendar. Include a time greater than 1 when the date object is created and problem is solved.

Change line 1272 in ui.datepicker.js or line 5801 in jquery.ui.all.js from: var printDate = new Date(drawYear, drawMonth, 1 - leadDays); to: var printDate = new Date(drawYear, drawMonth, 1 - leadDays,12);

comment:3 Changed 11 years ago by flesler

Resolution: invalid
Status: newclosed

This belongs to the UI Bug Tracker.

Note: See TracTickets for help on using tickets.