Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3543 closed bug (duplicate)

jquery dialog fix for transparent borders and backgrounds available, aswell as loading theme from json/database

Reported by: rene7705 Owned by: flesler
Priority: major Milestone: 1.3
Component: unfiled Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

for my CMS (http://mediabeez.veerman.ws/mb) i have implemented transparent borders on jQuery dialogs (ui-1.6b source).

To let semi-transparent borders work properly, a fix function must be called that corrects the margins and other layout properties of the dialog .ui-resizable-n/e/s/w etc divs.

To allow easy editing of themes, i have created another function that takes a blank dialog - stripped of (almost all?) css, and applies a JSON theme-definition to it, allowing CMS builders to store (and later edit) themes in their database rather than have to write out CSS files.

If you guys (and gals?) are interested in these functions they're available for free. I include only the fix for semi-transparent borders, coz i consider that one finished enough to share. The db-theme-apply function isn't ready for release yet, atm it uses a data-definition scheme of my cms rather than a generic one..

But i'm willing to put both in the public domain.

Change History (1)

comment:1 Changed 11 years ago by flesler

Resolution: duplicate
Status: newclosed

Duplicate of #3544.

Note: See TracTickets for help on using tickets.