Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3525 closed bug (invalid)

userAgentButton is null

Reported by: dklynn Owned by:
Priority: minor Milestone: 1.3
Component: core Version: 1.2.6
Keywords: userAgentButton Cc: dklynn, flesler
Blocked by: Blocking:

Description

Using FF 3.0.3 and jQuery 1.2.6, I'm getting a "userAgentButton is null" message on my websites as well as jquery.com (jquery.min.js (line 26) which is reported by FireBug as "for(handler in events[type])if(!parts[1]...ry.isReady)fn.call(document,jQuery);else". It doesn't appear to affect jQuery code but the reported error seems constant and is surely the sign of something gone wrong - but I'm not sure whether it's FireBug or jQuery.

Change History (9)

comment:1 Changed 11 years ago by flesler

Cc: dklynn flesler added
Milestone: 1.3
need: ReviewTest Case

There's nothing like userAgentButton in jQuery. Can you use the uncompressed version so we can spot the exact line ?

Try this: http://code.jquery.com/jquery-nightly.js

If you can include more details like the value of variables and stuff like that, it'd help.

comment:2 Changed 11 years ago by davidserduke

Are you using the User Agent Switcher plugin? If so, that might be the problem.

http://chrispederick.com/forums/viewtopic.php?id=2147

comment:3 Changed 11 years ago by dklynn

Thanks for the update. I've used the jquery-nightly.js and received:

Firebug's log limit has been reached. %S entries not shown. Preferences userAgentButton is null data()()jquery.js (line 683) trigger()()jquery.js (line 2027) triggerHandler()()jquery.js (line 2268) ready()()jquery.js (line 2335) [Break on this error] jQuery.cache[ id ][ name ] :

This was on line 683 which is:

jQuery.cache[ id ][ name ] :

Because this is new (and FF updates everything - so I'm sure I have the latest UserAgentSwitcher), I don't believe that (UAS) is the problem.

THANKS!

comment:4 Changed 11 years ago by dklynn

Oh, the jquery.js is the name I gave jquery-nightly.js on saving it - that's why it's denoted jquery.js in the Firebug error above.

comment:5 Changed 11 years ago by dklynn

... and the same error is given with Pedrick's userAgentSwitcher disabled.

comment:6 Changed 11 years ago by dklynn

flester,

I'll upload the nightly version (uncompressed) to the website where you should be able to see anything you need: http://datakoncepts.com/

THANKS!

DK

comment:7 Changed 11 years ago by dklynn

On THIS page, I get:

Firebug's log limit has been reached. %S entries not shown. Preferences userAgentButton is null ready()(Object originalEvent=Event load type=load)jquery.min.js (line 26) ready()(load )jquery.min.js (line 26) trigger()()jquery.min.js (line 25) [Break on this error] for(handler in events[type])if(!parts[1]...ry.isReady)fn.call(document,jQuery);else

which specifies jquery.min.js (line 26).

I hope this is not a FireFox problem (or a jQuery problem)!

Regards,

DK

comment:8 Changed 11 years ago by flesler

Resolution: invalid
Status: newclosed

I get no error on FF2 nor FF3.

I also found this(first link from google). I'm pretty sure this is an issue of that plugin, and for sure not from jQuery. There's no variable or method by that name in the source.

I'm going to close this for now.

comment:10 Changed 11 years ago by strings28

I want to quickly add that debugging through this shows that often the problem is with a Firefox defineGetter type assignment where the window.event object has been handled by jQuery. Appropriately fixed code (not a problem in jQuery) looks like this: Event.prototype.defineGetter("toElement", function() { fix: check for if(typeof(window.event) == 'undefined'){return;} ...rest of function...

Hope this helps someone

Note: See TracTickets for help on using tickets.