Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#349 closed bug (invalid)

Fix to API navigation in Safari

Reported by: remy@… Owned by:
Priority: minor Milestone:
Component: docs Version:
Keywords: Cc:
Blocked by: Blocking:

Description

The navigation for the API is broken in Safari, currently showing a list of random letters (mostly Js and Ss).

The bug is being caused by difference between the DOM in Safari.

The following line in 'js/doc.js:29':

return $.fn.text.apply( [a.childNodes[1]] ).replace(/^$./,"").substr(0,1).toUpperCase();

Should be changed to:

return $.fn.text.apply( [a.getElementsByTagName('SPAN')[2]] ).replace(/^$./,"").substr(0,1).toUpperCase();

Change History (1)

comment:1 Changed 13 years ago by joern

Resolution: invalid
Status: newclosed

The current API docs will be replaced with a new version soon that doesn't have that bug anymore.

Note: See TracTickets for help on using tickets.