Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3468 closed bug (duplicate)

maxlength attribute matches and returns -1 when not specified

Reported by: Phrogz Owned by: flesler
Priority: critical Milestone: 1.3
Component: unfiled Version: 1.2.6
Keywords: Cc: !@…
Blocked by: Blocking:

Description

With <input type="text|hidden"> with no maxlength attribute specified, this selector "input[maxlength]" matches the input. Further, theField.attr('maxlength') returns -1, where theField[0].getAttribute('maxlength') correctly returns null.

Experienced on FF3.0.3 on OS X.

Change History (1)

comment:1 Changed 11 years ago by brandon

Resolution: duplicate
Status: newclosed

duplicate of #3917

Note: See TracTickets for help on using tickets.