Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3458 closed bug (invalid)

Slow performance in IE6/7

Reported by: studlyswissdude2 Owned by:
Priority: major Milestone: 1.3
Component: ajax Version: 1.2.6
Keywords: Cc: studlyswissdude2, flesler
Blocked by: Blocking:

Description

When using .ajaxSubmit function, I am getting HTML back from the server and trying to insert that new HTML into a div, or rather replacing that DIV with the returned HTML code.

code: $("#"+$(data).attr("id")).after($(data)).remove();

As you can see, I'm inserting the new HTML code returned after the (div) id specified in the returned data and then remove the DIV. This works fine in FF and IE, however, if HTML data gets quite lengthy, the performance of this in IE is really poor, taking up to several minutes.

Any idea of another way of approaching this or what I could do to improve performance specifically in IE?

Change History (2)

comment:1 Changed 11 years ago by flesler

Cc: studlyswissdude2 flesler added
Component: unfilledajax
Owner: flesler deleted

comment:2 Changed 11 years ago by dmethvin

Resolution: invalid
Status: newclosed

You're better off asking questions like these in the forums, since it's not a bug.

Note: See TracTickets for help on using tickets.