Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3444 closed enhancement (duplicate)

Allow speed of 0 in animate to be instant

Reported by: jonahfox Owned by: flesler
Priority: minor Milestone: 1.3
Component: effects Version: 1.2.6
Keywords: css animate Cc:
Blocked by: Blocking:

Description

It would be really useful if $.fn.animate understood speed of 0 as being instant (rather than null => default speed)

I currently use the following to achieve this :

$.fn.animate2 = function(css, speed, fn) {

if(speed === 0) {

this.css(css) fn()

} else {

this.animate(css, speed, fn)

}

}

It is also in the best interest of accessibility to enable a way to disable all animations across the board, so putting this somewhere in core animation functions to recognize a 0 speed animation as synonym for .css would help in those efforts, should they exist.

see discussion here

http://groups.google.co.uk/group/jquery-dev/browse_thread/thread/524f3e1c22d730f7/921fcf2efd3798c3#921fcf2efd3798c3

Change History (2)

comment:1 Changed 11 years ago by flesler

Component: unfilledfx
need: ReviewPatch
Status: newassigned

comment:2 Changed 11 years ago by flesler

Resolution: duplicate
Status: assignedclosed

Oops.. I made a search inside Trac and couldn't find this ticket, so I created a new one.

Duplicate of #3495.

Note: See TracTickets for help on using tickets.