Bug Tracker

Opened 11 years ago

Closed 10 years ago

#3437 closed bug (invalid)

Bug in datepicker

Reported by: robertwgil Owned by:
Priority: critical Milestone: 1.3
Component: plugin Version: 1.2.6
Keywords: datepicker october Cc:
Blocked by: Blocking:

Description

On every october month, the second saturday and sunday of de second week, the day is the same.

Attachments (1)

testcal.html (872 bytes) - added by wdbaker54 11 years ago.
The test calendar I am using to see the problem with repeat Nov days

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by flesler

Please repost this to the UI Bug Tracker.

comment:2 Changed 11 years ago by wdbaker54

I am getting the same affect - except that it is any month of November (I went ahead to 2009, 2010 and 2011 to check) has the Monday following the first Sunday be the same day as Sunday. I am using the latest version of the UI and have checked that the problem is seen in multiple browsers.

Changed 11 years ago by wdbaker54

Attachment: testcal.html added

The test calendar I am using to see the problem with repeat Nov days

comment:3 Changed 11 years ago by flesler

Not here. Go to the UI bug tracker.

comment:4 Changed 11 years ago by jehinkle

The problem is daylight savings time. The Date object sets the year,month and day, but with no time specified defaults to midnight. So when the time increments by 1 day, and then daylight savings sets it back 1 hour, you get two November 2 on the calendar. Include a time greater than 1 when the date object is created and problem is solved.

Change line 1272 in ui.datepicker.js or line 5801 in jquery.ui.all.js from:

var printDate = new Date(drawYear, drawMonth, 1 - leadDays);

to:

var printDate = new Date(drawYear, drawMonth, 1 - leadDays,12);

comment:5 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

This is not a jQuery core bug. Please report plugin bugs to the plugin's author, or ask on the jQuery forums. jQuery UI bugs should be reported on the UI bug tracker, http://dev.jqueryui.com .

Note: See TracTickets for help on using tickets.