Bug Tracker

Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#3373 closed bug (invalid)

UI Date Picker in IE6 has "false" box

Reported by: Chalda Pnuzig Owned by: flesler
Priority: minor Milestone: 1.3
Component: unfiled Version: 1.2.6
Keywords: datepicker Cc:
Blocked by: Blocking:

Description

The problem is that in IE6 (testing in IE7 it looks fine), there is a box (an iframe?!?!?) below the calendar with the word false in it. When the first date picker is clicked, the box is the same size as the calendar. When another date picker is clicked on the same page the false box is twice as big. The box continues to grow in size every time a date picker is clicked.

There is problem also here: http://ui.jquery.com/repository/latest/demos/functional/#ui.datepicker

*UPDATE* I think the problem is MultipleIE

Attachments (2)

datepickerui.jpg (204.2 KB) - added by Chalda Pnuzig 12 years ago.
The box "False" in the first time
datepickerui2.jpg (174.2 KB) - added by Chalda Pnuzig 12 years ago.
The box "False" in the second time

Download all attachments as: .zip

Change History (5)

comment:1 in reply to:  description Changed 12 years ago by Chalda Pnuzi

*UPDATE* I think the problem is MultipleIE

I make a test now with IE6 on WinXp and the problem exists...

Changed 12 years ago by Chalda Pnuzig

Attachment: datepickerui.jpg added

The box "False" in the first time

Changed 12 years ago by Chalda Pnuzig

Attachment: datepickerui2.jpg added

The box "False" in the second time

comment:2 Changed 12 years ago by flesler

Resolution: invalid
Status: newclosed

Please repost this to the UI Bug Tracker.

comment:3 Changed 12 years ago by strechman

I do not have multipleIE installed but I can reproduce the issue on http://ui.jquery.com/repository/latest/demos/functional/#ui.datepicker. I was able to resolve issue with stylesheet definition. .ui-datepicker-cover {

display: none; display//: block; position: absolute; z-index: -1; filter: mask(); top: -4px; left: -4px; width: 193px; height: 200px;

} This is used for the iframe that is created. The sample page is missing this

Note: See TracTickets for help on using tickets.