Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3356 closed bug (fixed)

Validate plugin v 1.4 fails when no metadata is present

Reported by: mnichols Owned by: joern
Priority: major Milestone: 1.3
Component: plugin Version: 1.2.6
Keywords: Validate Cc:
Blocked by: Blocking:

Description

If this is in a form: <input class="required" type="text"/> and the form is validated with: jQuery("#demo_form").validate({meta:"validate"}); inside $.ready Then I get this : meta is undefined file:///C:/Development/Assets/test/datetime/jquery.validate.js Line 507 Which is caused by this: return meta.messages && meta.messages[method]; I think this is a new function in the 1.4 script but I think it should check for !meta before calling 'meta.messages' : if(!meta){ return; } This fixes the bug

Change History (2)

comment:1 Changed 11 years ago by joern

Owner: set to joern

comment:2 Changed 11 years ago by joern

Resolution: fixed
Status: newclosed

Fixed [5901].

Note: See TracTickets for help on using tickets.