Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3335 closed bug (worksforme)

NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN

Reported by: gipper Owned by: brandon
Priority: major Milestone: 1.3
Component: event Version: 1.2.6
Keywords: Cc: gipper, flesler
Blocked by: Blocking:

Description

Hellow. My script executes code:

$('form').bind( "change", function(event) { $(event.target).addClass('fieldChanged'); });

So, FireFox 3.0 give error:

uncaught exception: [Exception... "Cannot modify properties of a WrappedNative" nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)" location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onxblpopuphiding :: line 834" data: no]

What is this error? Help me please.

Change History (4)

comment:1 Changed 11 years ago by flesler

Cc: gipper flesler added
Component: coreevent
need: ReviewTest Case
Owner: set to brandon

Your details are not quite enough to be able to handle this. Could you provide a test case ? a minimalistic html file with the requires html and js to reproduce the problem. Thanks.

comment:2 Changed 11 years ago by dmethvin

Summary: Unknown errorNS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN

Googling seems to indicate that this is a XUL error?

comment:3 Changed 11 years ago by brandon

Resolution: worksforme
Status: newclosed

I'm unable to reproduce this. Feel free to reopen the ticket with a complete test case illustrating the issue.

comment:4 Changed 8 years ago by mail@…

To reproduce this error, here is a piece of code: lg george

<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8" />
    <title>Test</title>
        <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.7.0/jquery.min.js" type="text/javascript"></script>
  
</head>

<body>
    <div class="page">

        <header>
            <div id="title">
                <h1>My MVC Application</h1>
            </div>
          
        </header>
        <section id="main">
            <h2>
	Test</h2>

<form action="/Home/Test" method="post">	<table>
		<tr>
			<td>
				<input type="text" class="target" name="tbxNumber" value="10" id="tbxNumber01" oldvalue="10" />

			</td>
			<td>
				<input type="submit" name="inputSubmit" value="Submit" />
			</td>

			<td class="imageToUpdate">
				<img src="http://scripts.ringsworld.com/content-management/jetbox-cms-v2.1.sr1/jetbox/admin/cms/images/icon-alert-red.gif"
					alt="not saved" style="visibility: hidden" />
			</td>
		</tr>
		<tr>

			<td>
				<input type="text" class="target" name="tbxNumber" value="10" id="tbxNumber01" oldvalue="10" />
			</td>

			<td>
				<input type="submit" name="inputSubmit" value="Submit" />
			</td>
			<td class="imageToUpdate">
				<img src="http://scripts.ringsworld.com/content-management/jetbox-cms-v2.1.sr1/jetbox/admin/cms/images/icon-alert-red.gif"
					alt="not saved" style="visibility: hidden" />
			</td>

		</tr>
	</table>

</form>

<p>add a charactar to the textbox, and delete the charactar - you get an error in FF(8)</p>
<script type="text/javascript">


	$('[name="tbxNumber"]').keyup(function (event) {
		var oldValue = $(event.currentTarget).attr("oldvalue");
		if (oldValue != event.currentTarget.value) {
			// alert("new value");
			console.log($(this));
			$(this).parent().parent().find('img').css({ visibility: 'visible' });

		}
		else {
			$(this).parent().parent().find('img').css({ visibility: 'hidden' });

		}
	});
</script>

        </section>
        <footer>
        </footer>
    </div>
</body>
</html>


Note: See TracTickets for help on using tickets.