Bug Tracker

Opened 12 years ago

Closed 11 years ago

#3319 closed bug (duplicate)

After() bug in firefox 3

Reported by: nikavo Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc: nikavo, flesler
Blocked by: Blocking:

Description

Hello

Here is an exemple of bug error, thank you :

<script type='text/javascript' src='http://code.jquery.com/jquery.js'></script> <script type="text/javascript"> $(function() { $('#div2').insertBefore($('#div1')); }); </script> <body>

<div class="g" id="div1"> <script type="text/javascript" src="http://feedjit.com/serve/?bc=FFFFFF&amp;tc=494949&amp;brd1=336699&amp;lnk=494949&amp;hc=336699&amp;ww=160"></script><noscript><a href="http://feedjit.com/">Feedjit Live Blog Stats</a></noscript> </div> <div class="g" id="div2"> <script type="text/javascript" src="http://feedjit.com/map/?bc=FFFFFF&amp;tc=494949&amp;brd1=336699&amp;lnk=494949&amp;hc=336699&amp;dot=FF0000"></script><noscript><a href="http://feedjit.com/">Feedjit Live Blog Stats</a></noscript> </div> </body>

Attachments (1)

t.html (770 bytes) - added by nikavo 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by nikavo

Attachment: t.html added

comment:1 Changed 12 years ago by flesler

Cc: nikavo flesler added
Component: testscore
Owner: joern deleted

What is exactly the problem you see ? Your test case is far from valid html.

comment:2 Changed 12 years ago by nikavo

Thank you There is no problem if the html is not valid The problem that this exemple is bugging on firefox3, execute the code on firefox and see the source code!

Thank you!

<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN" "http://www.w3.org/TR/html4/loose.dtd"> <html> <head> <title></title> <script type='text/javascript' src='http://code.jquery.com/jquery.js'></script> <script type="text/javascript"> $(function() { $('#div2').insertBefore($('#div1')); }); </script> </head> <body> <div class="g" id="div1"> <script type="text/javascript" src="http://feedjit.com/serve/?bc=FFFFFF&amp;tc=494949&amp;brd1=336699&amp;lnk=494949&amp;hc=336699&amp;ww=160"></script> </div> <div class="g" id="div2"> <script type="text/javascript" src="http://feedjit.com/map/?bc=FFFFFF&amp;tc=494949&amp;brd1=336699&amp;lnk=494949&amp;hc=336699&amp;dot=FF0000"></script> </div> </body> </html>

comment:3 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #3105

Note: See TracTickets for help on using tickets.