Bug Tracker

Opened 12 years ago

Closed 12 years ago

#3318 closed bug (invalid)

find doesn't work in IE but works fine in Firefox

Reported by: ericerau Owned by:
Priority: minor Milestone: 1.3
Component: ajax Version: 1.2.6
Keywords: Cc: ericerau, flesler
Blocked by: Blocking:

Description

var s = "<Orders>" +

" <Order>" + " <OrderNo>12345</OrderNo>" + " <Path>this is the path value</Path>" + " <Base64>asdfasdfasdf.....sgdfgsdfg</Base64>" + " </Order>" + "</Order>";

alert($(s).find('Path').text())

This doesn't work in IE, but works fine in firefox. The code has been modified to do the test. In reality I didn't build the xml string like that. It was the result of a web service call. I considered a blocker because it makes the application unusable for Ajax. I have a post for this on experts exchange, check it out here:

http://www.experts-exchange.com/Web_Development/Web_Languages-Standards/XML/Q_23696687.html

If you have any questions email me at ericerau@…

Change History (3)

comment:1 Changed 12 years ago by flesler

Cc: ericerau flesler added
Component: coreajax
Milestone: 1.2.51.3
need: ReviewTest Case
Priority: blockerminor

Can you please provide a test case ? that is, a small html file with the minimum html/css/js necessary to reproduce the problem. Thanks

comment:3 Changed 12 years ago by dmethvin

Resolution: invalid
Status: newclosed

Yes, most likely IE is not happy trying to parse XML with its tag-soup parser. Try using the technique in the link above and reopen the ticket if a proper XML parser doesn't fix the issue.

Note: See TracTickets for help on using tickets.