Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3315 closed bug (duplicate)

Strange jQuery attributes cause selector to fail in IE

Reported by: raid_ox Owned by:
Priority: major Milestone: 1.3
Component: selector Version: 1.2.6
Keywords: selector, internet explorer, ie, html() Cc:
Blocked by: Blocking:

Description

In internet explorer, using $('selector').html() will emit strange jquery attributes that sometimes can cause problem:

$('#test').html() <-- <li jQuery32491238934="2"><span jQuery32491238934="null" class="name>...

the problem is, when you need to insert those string back to html, the selector won't work properly.

I created a demo to demonstrate this problem: http://code.riiv.net/demos/iebug.html

in ie, if you click get length, it will return 1, whereas in other browser 4.

any ideas?

Attachments (1)

ie7bug.html (1.4 KB) - added by raid_ox 11 years ago.
Test Case

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by raid_ox

Attachment: ie7bug.html added

Test Case

comment:1 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is a manifestation of #3254 so I'll close this ticket as a dup.

Note: See TracTickets for help on using tickets.