Bug Tracker

Opened 11 years ago

Closed 9 years ago

#3298 closed bug (worksforme)

animate string speeds 'show', 'hide' don't work as expected

Reported by: erangalp Owned by:
Priority: minor Milestone: 1.3
Component: effects Version: 1.2.6
Keywords: slide, animation Cc:
Blocked by: Blocking:

Description

When animating the CSS properties 'width' and 'height', the string speeds 'show' and 'hide' show a small stutter in certain conditions. Specifically, when the element being animated has padding, the animation will stop/start when the property is equal to 0 pixels, but still showing the padding. This might be by design, but the default slideDown / slideUp animations use this behavior, making them look less then ideal.

Attached use case shows two divs - one with padding and one without. The div with the padding is never really hidden (since it stops resizing at the padding).

Attachments (1)

testcase.zip (31.4 KB) - added by erangalp 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by erangalp

Attachment: testcase.zip added

comment:1 Changed 9 years ago by dmethvin

Resolution: worksforme
Status: newclosed

The CSS height/width excludes border and padding; you can animate those properties separately however using .animate() to get a smoother transition.

Note: See TracTickets for help on using tickets.