Bug Tracker

Opened 12 years ago

Closed 12 years ago

#3291 closed bug (invalid)

Error with value == NaN

Reported by: Dr4g0nF1y Owned by:
Priority: minor Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc: Dr4g0nF1y, flesler
Blocked by: Blocking:

Description

jQuery-1.2.6

problem row : 1120 [code] if( set )

elem [ name ] = value; is NaN

code

Attachments (2)

main.js (8.9 KB) - added by Dr4g0nF1y 12 years ago.
The script file that runs my website -- Error is IE only
error.js (875 bytes) - added by Dr4g0nF1y 12 years ago.
Short Version of the js-file. It's directly included and does not have external scripting on the HTML-file

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by Dr4g0nF1y

Attachment: main.js added

The script file that runs my website -- Error is IE only

comment:1 Changed 12 years ago by flesler

Cc: Dr4g0nF1y flesler added
need: ReviewTest Case

Can you please provide a test case ? that is, a small html file with the minimum html/css/js necessary to reproduce the problem. Please keep it simple, the js you provide is way too long.

comment:2 Changed 12 years ago by flesler

Priority: blockerminor

comment:3 in reply to:  2 Changed 12 years ago by Dr4g0nF1y

Replying to flesler:

I considered this error a blocker since it runs my website in IE useless.

Although I didn't use things I shouldn't or couldn't use. In FF it runs like a charm, but in IE I get an error that the action I want to run is not supported by the object.

After that I get an runtime error that is thrown at the code above. Checking wether the value is NaN and thus a getter instead of a setter, does not help.

Changed 12 years ago by Dr4g0nF1y

Attachment: error.js added

Short Version of the js-file. It's directly included and does not have external scripting on the HTML-file

comment:4 Changed 12 years ago by flesler

The priority is in relation to the framework, not to your personal work. Will try to check the test case as soon as I can. Thanks

comment:5 Changed 12 years ago by Dr4g0nF1y

http://nieuw.motoerit.nl/

you can test here. it's the page that jams in IE

comment:6 Changed 12 years ago by Dr4g0nF1y

By using the microsoft script debugger, I found the culprit... it's an jQuery Plugin called "jMyCarousel".

If you have MSD, follow the callstack, and you'll see it.

Somewhere between the call for the "getcontent" and the error, the value of the function -which produces the error- get's to NaN.

comment:7 Changed 12 years ago by flesler

Then how come the 2nd js file attached doesn't call the plugin and you still mention an error ? That means error.js doesn't trigger any error ?

comment:8 in reply to:  7 Changed 12 years ago by Dr4g0nF1y

Replying to flesler:

Then how come the 2nd js file attached doesn't call the plugin and you still mention an error ? That means error.js doesn't trigger any error ?

That is because it is called in the first file. And at the time I didn't know that it was the plugin that caused the error.

But I guess that should be obvious. I understand that a smaller file is advised/prefered, but since not everyone can actually find the error, a little effort for the bigger file (or a request of the issueing url) is not useless.

I have rebuild my Internet Explorer version of the script, and thus can this ticket be closed. Not to my satisfaction, but that is not the cause of jQuery or it's developers but a 3rd party.

I thank you (all) for your time and effort.

comment:9 Changed 12 years ago by flesler

Resolution: invalid
Status: newclosed

Ok, thanks.

Note: See TracTickets for help on using tickets.