Bug Tracker

Opened 8 years ago

Closed 8 years ago

#3241 closed enhancement (fixed)

Why setting the length to 0 on jQuery's prototype ?

Reported by: flesler Owned by: flesler
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

I think this is rather useless: Line 93 & 94.

// The number of elements contained in the matched element set
  length: 0,

I recall this causing me problems when iterating the prototype. Can't reproduce that though. Still, seems like useless code. All the tests pass without that.

Attachments (1)

length[5819].diff (419 bytes) - added by flesler 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by flesler

comment:1 Changed 8 years ago by flesler

  • need changed from Patch to Commit
  • Status changed from new to assigned

comment:2 Changed 8 years ago by flesler

  • Resolution set to fixed
  • Status changed from assigned to closed

Applied at [5820].

Note: See TracTickets for help on using tickets.