Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3217 closed bug (duplicate)

wrong document context in .clone (in IE)

Reported by: fabiangebert Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: clone, ie, context Cc:
Blocked by: Blocking:

Description

Instead of

container = this.ownerDocument.createElement("div");
container.appendChild(clone);
return jQuery.clean([container.innerHTML],this.ownerDocument)[0];

It should be

container = this.ownerDocument.createElement("div");
container.appendChild(clone);
return jQuery.clean([container.innerHTML],this.ownerDocument)[0];

in the .clone() function.
If not, the code does not work with frames (invalid argument error).

Change History (2)

comment:1 Changed 11 years ago by shazam

Already spotted see ticket #2997

comment:2 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #2997

Note: See TracTickets for help on using tickets.