Bug Tracker

Opened 12 years ago

Closed 12 years ago

#3158 closed bug (fixed)

"1 item remaining" issue in IE

Reported by: enots Owned by:
Priority: major Milestone: 1.2.3
Component: event Version: 1.2.1
Keywords: Cc:
Blocked by: Blocking:

Description

Sometimes in IE 7 a page with jQuery.js included never loads completely. In the status bar it says "1 item remaining". As a result the document.ready function never runs. I found that this problem has to do with the next line in jQuery.js:

document.write("<scr" + "ipt id=ie_init defer=true " +

"src=:><\/script>");

This problem can be solved by changing src=: into scr=blank.js, where blank.js is probably a nonexisting file.

This problem occurs in other javascript libraries as well. I solved this jQuery problem with the comment at: http://groups.google.com/group/prototype-scriptaculous/browse_thread/thread/a1c745463251a95d

Maybe there is a better fix than using blank.js. I thought I send this in as a ticket. It took me lots of time to solve this problem. It is hard to reproduce this issue. I cannot give you access to the web application where we struggled with this issue, as it is an secure site with medical personal data.

Thanks for jQuery!

Enots

Change History (2)

comment:1 Changed 12 years ago by flesler

Component: coreevent
Milestone: 1.2.11.3
Version: 1.2.11.2.6

comment:2 Changed 12 years ago by davidserduke

Milestone: 1.31.2.3
Resolution: fixed
Status: newclosed
Version: 1.2.61.2.1

I see this was originally reported with version 1.2.1 so it was likely fixed by 1.2.3 where the document.write() trick was no longer used. But since it was reported 4 months ago which is after 1.2.3 went final perhaps there is still a problem here that I don't understand. If that is the case, please reopen the ticket with more information.

Note: See TracTickets for help on using tickets.