Bug Tracker

Opened 11 years ago

Closed 9 years ago

#3148 closed bug (invalid)

Sortable items within table + float:left + IE7 = items not displayed

Reported by: thye Owned by:
Priority: major Milestone:
Component: core Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

I entered the following ticket in Jquery UI trac (#3034) but was told that it is a Jquery core bug.

Comment from Paul: This is not a bug within sortables, but apparently within the jQuery core - setting css("position", "relative") on the container causes the behaviour - but it's not like that if you set it in the style attribute before explicitely.

Would be great if you could enter it again in http://dev.jquery.com/newticket. Thanks''


Try the following html with jquery.ui 1.5 in Firefox, you can see item 1, 2 and 3. Try it in IE7, you see nothing. The bug occurred when sortable items are 'floated' and within a table.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html>
<head>
<script type="text/javascript" src="jquery-1.2.6.min.js"></script>
<script type="text/javascript" src="ui.core.min.js"></script>
<script type="text/javascript" src="ui.sortable.min.js"></script>
<script type="text/javascript">
$(document).ready(function(){
	$('#mylist').sortable();
});

</script>
<style>

ul { list-style-type: none; }
ul li { float: left; }

</style>
</head>
<body>

<table>
<tr>
<td>

	<div>
	<ul id=mylist>
		<li>item 1</li>
		<li>item 2</li>
		<li>item 3</li>
	</ul>
	</div>

</td>
</tr>
</table>

</body>
</html>

Change History (2)

comment:1 Changed 11 years ago by flesler

I'll ask Paul about this. I've no idea what is done inside that sortable() call.

comment:2 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

Since this bug is pretty stale now I'll close it. If the problem can be reproduced in 1.4.2 please open a ticket with a test case and details.

Note: See TracTickets for help on using tickets.