Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3142 closed bug (duplicate)

"Object doesn't support this property or method" error in MSIE 7 with connected sortable lists containing objects (flash files)

Reported by: weapey Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: ajax Cc:
Blocked by: Blocking:

Description

I've been working on an application that uses flash charts in 3 sortable lists all connected to mimic a dashboard where users can drag the panels around in whichever comment they want, then an ajax call is made to store the positions of each graph.

I've been having a problem with MS Internet Explorer 7 however. If you have a list which contains multiple flash objects, the second call to $.ajax or any of its higher level implementations will result in an error if it was called from a callback function of the sortable lists.

This does not result in an error in Firefox. I have not tested it in any other browsers.

The attached files demonstrate the problem the best I can.

Attachments (2)

test.html (4.5 KB) - added by weapey 11 years ago.
test.html (reqiures jquery-1.2.6.js and jquery.ui.all.js)
Pie3D.swf (50.5 KB) - added by weapey 11 years ago.
Developed by FusionCharts

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by weapey

Attachment: test.html added

test.html (reqiures jquery-1.2.6.js and jquery.ui.all.js)

Changed 11 years ago by weapey

Attachment: Pie3D.swf added

Developed by FusionCharts

comment:1 Changed 11 years ago by flesler

Component: coreajax

comment:2 Changed 11 years ago by john

Component: ajaxcore
Resolution: duplicate
Status: newclosed

Duplicate of #2845.

Note: See TracTickets for help on using tickets.