Bug Tracker

Opened 12 years ago

Closed 11 years ago

#3095 closed bug (duplicate)

Ajax + FF3 conflict: Unwanted refresh due to re-extend 's'

Reported by: abo Owned by:
Priority: minor Milestone: 1.3
Component: ajax Version: 1.2.6
Keywords: post ajax extend refresh Cc:
Blocked by: Blocking:

Description

ajax: function( s ) {
    // Extend the settings, but re-extend 's' so that it can be
    // checked again later (in the test suite, specifically)
    s = jQuery.extend(true, s, jQuery.extend(true, {}, jQuery.ajaxSettings, s));
    ...
}

Re-extending 's' seems to conflict with Firefox 3 when doing an ajax post; An unnecessary refresh occurs.

Without the re-extend (like below) it works like a charm in all browsers.

ajax: function( s ) {
    s = jQuery.extend(true, {}, jQuery.ajaxSettings, s));
    ...
}

Change History (2)

comment:1 Changed 12 years ago by flesler

need: CommitTest Case

Can you please provide a test case ? that is, a small html file with the minimum html/css/js necessary to reproduce the problem. Thanks

comment:2 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #5439 (fixed).

Note: See TracTickets for help on using tickets.