Bug Tracker

Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#3092 closed bug (duplicate)

outerWidth(true) returns wrong values in Safari

Reported by: aaronchi Owned by: brandon
Priority: major Milestone:
Component: dimensions Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

When calculating outerWidth(true) in Safari, the value returned is the width + visual margin (width of the parent element) rather than the width + margin of the actual element.

Works correctly in IE & Firefox.

Change History (4)

comment:1 Changed 7 years ago by brandon

  • Resolution set to worksforme
  • Status changed from new to closed

This works for me with the latest jQuery. Please feel free to reopen with a complete test case showing the issue you are having.

comment:2 Changed 5 years ago by jitter

  • Milestone 1.3 deleted
  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:3 Changed 5 years ago by jitter

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:4 Changed 5 years ago by jitter

Duplicate of #3333.

Note: See TracTickets for help on using tickets.