Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3064 closed bug (invalid)

erratic results with .val() assignment

Reported by: jkeane Owned by:
Priority: minor Milestone: 1.3
Component: core Version: 1.2.6
Keywords: val select Cc: jkeane
Blocked by: Blocking:

Description

When I loop over an array of field names (like so): $.each(populateFields,function() { $("#"+this).val(r.data[this.toLowerCase()]); });

jQuery doesn't always properly assign values to select elements.

Attachments (2)

3064.html (2.5 KB) - added by nathanhammond 11 years ago.
Test Case
3064.2.html (2.9 KB) - added by nathanhammond 11 years ago.
Test Case 2

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by flesler

need: ReviewTest Case
Priority: criticalminor

Your details are not quite enough to be able to handle this. Could you provide a test case ? a minimalistic html file with the requires html and js to reproduce the problem. Thanks.

Changed 11 years ago by nathanhammond

Attachment: 3064.html added

Test Case

comment:2 Changed 11 years ago by nathanhammon

The test case I've attached works as expected in my versions of FF, Opera, and Safari (all latest). It does not work in any version of IE (6, 7, 8b1--using IETester).

Any thoughts before I create a patch?

comment:3 Changed 11 years ago by flesler

Cc: jkeane added

That's not the same situation the reporter described.

Changed 11 years ago by nathanhammond

Attachment: 3064.2.html added

Test Case 2

comment:4 Changed 11 years ago by nathanhammon

Test Case 2 attached, using code identical to the reporter's. I cannot get this one to fail anywhere. Worksforme?

Original test case will be filed as a new bug since the issue is apparently different.

comment:5 Changed 11 years ago by flesler

Resolution: invalid
Status: newclosed

Ok, it's mostly useless to suppose what the reporter meant, he should be the one providing a test case I think. The description is too vague, and the reporter isn't replying. So I'll close this.

To the reporter: if you want, reopen with a valid test case.

Note: See TracTickets for help on using tickets.