Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3056 closed bug (invalid)

bug in attr

Reported by: vevni133 Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: attr Cc:
Blocked by: Blocking:

Description

i found a bug trying to use this

$("#my_div").attr({

style: "", class: ""

});

IE7 and 6 sucks when i use that code FF no problem.

Attachments (1)

jqueryTest.htm (634 bytes) - added by pr 11 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by flesler

need: ReviewTest Case

Could you provide a test case ? a minimalistic html file with the requires html and js to reproduce the problem. Also, describe what do you mean by "sucks". It errors, ignores it, closes down... ? Thanks.

Changed 11 years ago by pr

Attachment: jqueryTest.htm added

comment:2 Changed 11 years ago by pr

The problem is not related to jQuery but rather with IE (tried on IE6)

the issue seems to be a parse error when IE sees the class.

this fixes the issue and works as expected (removes the class)

$("#my_div").attr({

class: "" This causes a parse error in IE "class": "" This fixes it.

});

comment:3 Changed 11 years ago by pr

sorry for the bad formatting this fixes it $("#my_div").attr({

class: "" This causes a parse error in IE

"class": "" This fixes it.

});

comment:4 Changed 11 years ago by flesler

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.