Bug Tracker

Opened 12 years ago

Closed 11 years ago

#3038 closed bug (duplicate)

show() function fails on Safari under unknown circumstances

Reported by: poorladrob Owned by:
Priority: critical Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by john)

Hi there, my name is Rob Wright, working for a large financial organisation implementing jQuery in one of our applications.

It appears that under certain circumstances the show() function fails, certainly under Safari 3.1.1, and I've had to resort to using css('display', 'block') in order to display the matched elements.

I have not isolated it into a test case as yet, but you can see the issue here on one of our sites. We have a non-Ajax version of the form and an Ajax version that is set up upon page load, and as part of that function we're having to show and hide some elements using the CSS function because the show() is inoperable.

A quick Google search suggests others have had similar problems but have not submitted a ticket, according to John.

Many thanks to anyone who can shed some light on this.

Attachments (1)

testcase.zip (17.2 KB) - added by poorladrob 12 years ago.
Test case that fails in Safari 3.1.1

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by john

Priority: majorcritical

comment:2 Changed 12 years ago by john

Description: modified (diff)

Changed 12 years ago by poorladrob

Attachment: testcase.zip added

Test case that fails in Safari 3.1.1

comment:3 Changed 12 years ago by poorladrob

Of note - if the element is initially hidden with inline styling, the bug doesn't occur. If it's hidden in an external stylesheet, the bug is triggered. See test case.

comment:4 Changed 11 years ago by djmccormick

I'm also having this issue. For now I'm using .css('display', 'none') and .css('display', 'block') to get around it.

comment:5 Changed 11 years ago by DavidDecraen

I'm having the same issue, and can perhaps provide a bit more context: To me it consistently and reproducibly happens on an element that has been removed by calling the remove function on it, but saved as a javascript variable:

See live page at: http://jowl.ontologyonline.org/wine_demo.html

Hit search, the search results provide a tooltip (on hovering) in which certain elements refuse to be hidden in Safari. Compare with firefox or Internet Explorer to see that in those browsers the same elements are hidden.

comment:6 in reply to:  description Changed 11 years ago by DavidDecraen

Any updates on this issue?

comment:7 Changed 11 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #1239.

Note: See TracTickets for help on using tickets.