Bug Tracker

Opened 11 years ago

Closed 9 years ago

#3027 closed bug (worksforme)

triggering focus throws to events in IE

Reported by: trixi Owned by: flesler
Priority: minor Milestone: 1.3
Component: event Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

If you use elm.trigger("focus");. IE will throw 2 events. (1 fake and 1 original)

Attachments (2)

focus_doubble.patch (1.2 KB) - added by trixi 11 years ago.
trigger-test.html (768 bytes) - added by trixi 11 years ago.
test case for ie7 trigger('focus') bug

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by trixi

Attachment: focus_doubble.patch added

comment:1 Changed 11 years ago by flesler

need: ReviewTest Case
Priority: majorminor

Your details are not quite enough to be able to handle this. Could you provide a test case ? a minimalistic html file with the requires html and js to reproduce the problem. Thanks.

Changed 11 years ago by trixi

Attachment: trigger-test.html added

test case for ie7 trigger('focus') bug

comment:2 Changed 11 years ago by flesler

Owner: set to flesler
Status: newassigned

Ok, we'll review it. Thanks.

comment:3 Changed 11 years ago by flesler

need: Test CasePatch

comment:4 Changed 9 years ago by addyosmani

Resolution: worksforme
Status: assignedclosed

Reducing your test case to testing trigger and using jQuery 1.4.4 this seems to be working fine in IE6/7/8 and as per other browsers such as Chrome, FireFox etc. Live Test Case

Note: See TracTickets for help on using tickets.