Bug Tracker

Opened 12 years ago

Closed 12 years ago

#3018 closed bug (duplicate)

Using AJAX type=script or type=jsonp on IE6 sometimes breaks

Reported by: bgoldman Owned by:
Priority: major Milestone: 1.3
Component: ajax Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

On IE6, I noticed that one of my AJAX requests was failing. The AJAX request was using type=jsonp. After doing a very thorough round of testing and trying to narrow down the bug, I came to the conclusion that when using type=script or type=jsonp, IE6 fails if also the page making the AJAX request is inside an iframe, and also if Cache-control is set to no-store, and also only if the url being called is on a different domain. It's a very obscure IE6 bug. I found that a solution to this bug was modifying jQuery to use document.body.appendChild(script) instead of head.appendChild(script). I think a good fix in jQuery would be to just append to document.body instead of head. So instead of creating a head variable which is used to append for cross-domain script/jsonp, just make a generic script_parent or something.

Change History (1)

comment:1 Changed 12 years ago by flesler

Resolution: duplicate
Status: newclosed

Duplicate of #3019.

Note: See TracTickets for help on using tickets.