Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2979 closed bug (wontfix)

removeAttr on IE7 need a click over the element need 2 steps

Reported by: harlok Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: IE7 removeAttr disabled Cc:
Blocked by: Blocking:

Description

Hi, when you have a input element disabled for example:

<select id="textfield" name="" disabled="disabled">

<option value="1">a</option> <option value="2">b</option>

</select>

and need change disabled attribute, with one checkbox...

<input type="checkbox" id="checkbox" onchange="out();"/>

and JS code...

function out(){

$("#textfield").removeAttr('disabled','disabled');

}

In FF we have no problem, but in IE7, after you click in the checkbox, you need to click hover the select to make the change.

Change History (1)

comment:1 Changed 12 years ago by flesler

Resolution: wontfix
Status: newclosed

If I'm not getting it wrong... the problem is that IE (6 too) doesn't trigger the change event until the checkbox loses focus (blur). As you can see yourself, this is not a jQuery issue and it's quite hard to work around. We don't provide a hack for this, is the native behavior of the browser.

Cheers, reopen if you have anything else to say.

Note: See TracTickets for help on using tickets.