Bug Tracker

Opened 13 years ago

Closed 13 years ago

#2961 closed bug (invalid)

Empty() makes the field unusable.

Reported by: arustgi Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.5
Keywords: Cc:
Blocked by: Blocking:

Description

Refer to the simple HTML file attached:

Once you call the empty function on the the drop down, you can not manipulate it it any other manner. In the attached html, once I click on the test button, i cannot manipulate the contents of the dropdown.

To reproduce:

  1. Click on the Test button. It will remove the content of the dropdown.
  2. Click on the Test2 button. It will do nothing.

Refresh the page

  1. Clock on the Test2 button. Verify that colorado is added to the drop down.
  2. Click on the Test button. It will remove the content of the dropdown.
  3. Click on the Test2 button agian. It will not be able to add the colorado to dropdown

Attachments (1)

HTMLPage1.htm (972 bytes) - added by arustgi 13 years ago.
Test File to reproduce behavior

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by arustgi

Attachment: HTMLPage1.htm added

Test File to reproduce behavior

comment:1 Changed 13 years ago by flesler

Resolution: invalid
Status: newclosed

Well obviously! wrapInner wraps the children inside an element. You can't "wrapInner" with no children. In that case, you are meant to simply use append.

I'll close this as invalid. Checked the source and this is the expected behavior, definitely not a bug.

Note: See TracTickets for help on using tickets.