Bug Tracker

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#2947 closed bug (fixed)

Event: altKey not set

Reported by: ivan Owned by: flesler
Priority: minor Milestone: 1.3
Component: event Version: 1.2.5
Keywords: Cc:
Blocked by: Blocking:

Description

The altKey field is not set in the Event object.

Attachments (1)

event.js.patch (671 bytes) - added by ivan 12 years ago.
Patch

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by ivan

Attachment: event.js.patch added

Patch

comment:1 Changed 12 years ago by flesler

need: ReviewTest Case
Owner: set to flesler
Status: newassigned

The patch is invalid, it won't add altKey.

Can you provide a test case where we can see the altKey missing ?

Thanks

comment:2 Changed 12 years ago by nostrademons

I'm getting this too. Test case:

http://dev.diffle.com/jonathan/public/jquery_bug_2947/

Ivan's patch is valid. The problem is an off-by-1 error when it's looping through the fields: it starts at props.length (which is an invalid index), and ends at i = 1. When i = 0, the loop condition is false and so it doesn't perform the iteration that would assign altKey.

comment:3 Changed 12 years ago by ivan

Sorry I haven't been around. Thanks nostrademons for providing the test case and explanation.

comment:4 Changed 11 years ago by flesler

Resolution: fixed
Status: assignedclosed

Right, got it now. I actually fixed this some weeks ago, I thought it made it into 1.2.6 but now I realize it didn't :(

Could you check this with the version in the trunk ?

Please reopen if that one still fails.

Thanks.

comment:5 Changed 11 years ago by flesler

This was fixed on [5707].

Note: See TracTickets for help on using tickets.