Bug Tracker

Opened 12 years ago

Closed 11 years ago

#2910 closed bug (invalid)

:visible not working on safari

Reported by: balliano Owned by:
Priority: major Milestone: 1.2.4
Component: core Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

this is a 1.2.5 bug

i've a <div class="someclass"></div>

where .someclass is {

display: none;

}

and the jquery code

$(".someclass:visible").dosomething()

it's not working on safari 3.1 windows

Change History (4)

comment:1 Changed 12 years ago by balliano

the demo here: http://docs.jquery.com/Selectors/visible is working on safari, thus i'm thinking if the problem is concerning the fact that my css is an external file...

maybe the dom is considered ready before loading css?

comment:2 Changed 12 years ago by balliano

yes, adding inline style="display:none" is a workaround but it's not the best...

comment:3 Changed 12 years ago by balliano

it seems that both are solved including the CSS files before the JS, solving other dimensions related issues (most on opera) too

comment:4 Changed 11 years ago by dmethvin

Resolution: invalid
Status: newclosed

With jQuery 1.3 we've documented the requirement to include CSS before script for proper operation on Safari.

Note: See TracTickets for help on using tickets.