Bug Tracker

Opened 12 years ago

Closed 11 years ago

#2859 closed bug (fixed)

Datepicker 3.4.3 'change' commits changes to all datepickers

Reported by: mnichols Owned by: kbwood
Priority: critical Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: datepicker 3.4.3 change Cc:
Blocked by: Blocking:

Description

When trying to use the 'change' function, the new settings are applied to all datepickers on page. For example, with the code below, one would expect that only the input 'myrange' would be a ranged datepicker, but in fact it causes all pickers to become range-aware. If this is by design it should be made clearer.

To test: <input type="text" class="date" id="plainoledate"/> <script type="text/javascript"> $(document).ready(function(){ $('.date').datepicker(); }); </script> <input type="text" class="date" id="myrange"/> <script type="text/javascript"> $(document).ready(function(){ $('#myrange').datepicker('change',{ rangeSelect: true}); }); </script>

Change History (2)

comment:1 Changed 11 years ago by paul

Owner: changed from paul to kbwood

comment:2 Changed 11 years ago by kbwood

Resolution: fixed
Status: newclosed

Fixed. Change should only affect the targetted controls.

Note: See TracTickets for help on using tickets.