Bug Tracker

Opened 13 years ago

Closed 10 years ago

#279 closed (invalid)

Ben

Reported by: Fil Owned by:
Priority: Milestone:
Component: Version:
Keywords: SPAM Cc:
Blocked by: Blocking:

Description (last modified by dmethvin)

If I do

$("a").filter(".x,.y.z")

I don't get the correct selection.

I would have expected to get the same as $("a.x").add("a.y").add("a.z")

PS: version 1.0.2

Change History (7)

comment:1 Changed 13 years ago by Fil

Sorry I typed the bug report wrong (shame!)

The code should have said: $("a").filter(".x,.y,.z")

The bug stands.

comment:2 Changed 13 years ago by john

Type: bugenhancement

This is already implemented in jQuery, just differently. You can do: $("a").filter([".x", ".y", ".z"]) and it will work as expected.

Having it also work with commas ',' would be nice, but its certainly not a bug.

comment:3 Changed 13 years ago by Ben

Cc: Ben added; {empty} removed
Component: 1
Keywords: Ben added; {empty} removed
Milestone: 1
Priority: 1
Summary: {empty}Ben
Type: 1
Version: 1

comment:4 Changed 10 years ago by dmethvin

Description: modified (diff)
need: Review

comment:5 Changed 10 years ago by dmethvin

Component: 1unfilled
Keywords: SPAM added; Ben removed
Priority: 1trivial
Resolution: invalid
Status: newclosed

SPAM

comment:6 Changed 9 years ago by snover

Component: unfiled
Milestone: 1
Priority: trivial
Type: 1
Version: 1

comment:7 Changed 9 years ago by snover

Cc: Ben removed
Owner: {empty} deleted
Note: See TracTickets for help on using tickets.