Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2753 closed bug (invalid)

jQuery UI sortables: "helper" item not visible when dragging between scrollable divs.

Reported by: wang Owned by: paul
Priority: major Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: sortable overflow Cc:
Blocked by: Blocking:

Description

When dragging an item from one connected list to another (the lists are in separate divs), the helper item becomes invisible.

This only happens when one (or both) of the divs are scrollable ("overflow: scroll").

This has been tested on XP in IE7 and Fx2, and on Leopard in Fx3b5 and Safari 3.1. Please see attachment for an example.

Attachments (1)

disappear.html (2.6 KB) - added by wang 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by wang

Attachment: disappear.html added

comment:1 Changed 12 years ago by paul

Status: newassigned

comment:2 Changed 12 years ago by paul

Resolution: invalid
Status: assignedclosed

That's not a bug - it happens because the helper is appended to the parent, and therefore cannot be moved out. Try using the appendTo option to append the helper to a higher node, i.e "body"

Note: See TracTickets for help on using tickets.