Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2702 closed bug (duplicate)

Wrap manipulation resets state of radiobutton in IE

Reported by: e-andy Owned by:
Priority: major Milestone: 1.2.3
Component: core Version: 1.2.3
Keywords: wrap attributes Cc: e-andy@…
Blocked by: Blocking:

Description

Wrap manipulation resets state of radiobutton in IE 6 only (6.0.2900.2180 sp2)

For example:

<html> <head>

<script type="text/javascript" src="/media/inc/jquery/main/v1.2.3/jquery.min.js"></script> <script type="text/javascript">

$("form").ready(function() {

$(":radio[name=xxx][value=1]").attr("checked", "true"); value may be "1", true, "yes" etc - result doesnt change alert($(":radio[name=xxx][value=1]").attr("checked")); $("span").wrap("<div></div>"); alert($(":radio[name=xxx][value=1]").attr("checked"));

});

</script>

</head> <body> <label>

<form>

<span>

<input type="radio" name="xxx" value="1"/>yes <input type="radio" name="xxx" value="0"/>no

</span>

</form>

</label> </body> </html>

Change History (1)

comment:1 Changed 12 years ago by davidserduke

Resolution: duplicate
Status: newclosed

duplicate of #2703

Note: See TracTickets for help on using tickets.