Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2686 closed bug (fixed)

Sortable bug

Reported by: sheraz Owned by: paul
Priority: major Milestone: 1.2.3
Component: ui Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

If i apply sortable to any list then that element or any of its child elements cannot fire click event. See the sample code below. The click event works fine if i comment out the sortable line.

<ul id="testUL">

<li>

A <ul>

<li>A.1</li> <li>A.2</li> <li>A.3</li>

</ul>

</li> <li>B</li> <li>C</li>

</ul>

$("#testUL").sortable({}); $("#testUL").click(function() { console.log("test has been clicked"); } );

Any advise on that champs ?

Change History (3)

comment:1 Changed 12 years ago by sheraz

I forgot to mention one thing in my post - i am using latest version of JQuery (1.2.3) & UI (1.5b). I think the problem is with the "ui.sortable.js" from version 1.5b because if i replace this file by the following two files (1) http://dev.jquery.com/view/tags/ui/1.0.1a/ui.sortable.js (2) http://dev.jquery.com/view/tags/ui/1.0.1a/ui.mouse.js then the click event starts working correctly. I hope this will help you in figuring out the problem.

comment:2 Changed 12 years ago by dmclain

Can you please CC Me on this ticket? I have the same problem.

dmclain@…

Thanks!!

comment:3 Changed 12 years ago by paul

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.