Bug Tracker

Opened 12 years ago

Closed 12 years ago

Last modified 7 years ago

#2675 closed bug (worksforme)

toJSONString button in dialog in JQuery UI 1.5b

Reported by: bart.waggoner Owned by: rworth
Priority: major Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

When showing a dialog with an OK and Cancel button, I also get a toJSONString button. I presume this is for debugging purposes, but I did not see an easy way to turn it off. JQuery UI 1.5b.

Here is how I create the dialog:

$("#sqlDlg").dialog({

title: "SQL Expression", buttons: { "OK": sqlDoOk, "Cancel": sqlDoCancel }, height: 225, width: 530

});

Change History (3)

comment:1 Changed 12 years ago by paul

Owner: changed from paul to rworth

comment:2 Changed 12 years ago by rworth

Resolution: worksforme
Status: newclosed

I was not able to reproduce with the latest beta (1.5b2). If you're able to, please reopen and attach a test page demonstrating it.

comment:3 Changed 7 years ago by danclaude@…

Happened to me recently in IE8, while in IE7-compatibility mode. It appears as if built-in objects like string and boolean have an additional "toJSON"-method in that mode, which is what gets rendered as a button.

Note: See TracTickets for help on using tickets.