Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2564 closed enhancement (duplicate)

event.fix performance tweaks patch

Reported by: diego Owned by:
Priority: major Milestone: 1.2.4
Component: core Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

Using lazy function definition it is possible to optimize quite consistently the performances of the event.fix() method.

This is a first tentative rewrite, I tried to adhere as much as possible to the restriction I learned in the forum, I mean return a writable event object.

I have executed the jQuery automated test suite and it passes all the tests, it also passes the "fix.html" and "offset.html" tests I found there. I have not built specific test using Custom Events but should work too with no changes for plugins developers (hope so).

For standard events I believe I have done more tests, and I have stressed it enough with the test I had already post in the forum.

Here is the DIFF patch to apply to the "event.js" source file, the patch may be used to directly patch a copy of "jquery-1.2.3.js" if somebody want to help with testing without downloading the build.

Cheers,

Diego Perini

Change History (1)

comment:1 Changed 12 years ago by brandon

Resolution: duplicate
Status: newclosed

duplicate of #2565

Note: See TracTickets for help on using tickets.