Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2498 closed bug (worksforme)

Jquery Validate Plugin

Reported by: mrpollo Owned by: joern
Priority: minor Milestone: 1.2.4
Component: plugin Version: 1.2.3
Keywords: validate plugin Cc:
Blocked by: Blocking:

Description (last modified by joern)

lets see the scenario:
validate()
then set rules
rules:{} //normal stuff in here
then i go and place the messages
messages:{} // i just keep it simple
then my error stuff
errorPlacement:{}
and finally i get the success
success:{}
here starts the problem
whenever i try and submit the form
everything blank, it displays all of the error messages correctly
then lets say i had this input that required text in it, i write something in it and the success fires perfectly, but the problem is when i again delete that field the errorPlacement doesnt fire again till i press submit again, so we are left with no correct response in here

i attached my code

mrpollo@gmail.com

Attachments (1)

example.html (8.1 KB) - added by mrpollo 12 years ago.
test scenario i used

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by mrpollo

Attachment: example.html added

test scenario i used

comment:1 Changed 12 years ago by scott.gonzal

Owner: set to joern

comment:2 Changed 12 years ago by joern

Description: modified (diff)

comment:3 Changed 12 years ago by joern

Resolution: worksforme
Status: newclosed

errorPlacement is called only when inserting the error in the DOM the first time, never again. To add and remove classes, use highlight und unhighlight instead. See the docs for details: http://docs.jquery.com/Plugins/Validation/validate (Options tab, scroll down to the bottom).

Please reopen the ticket if highlight/unhighlight don't help with this issue.

Note: See TracTickets for help on using tickets.