Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2482 closed bug (duplicate)

UI 1.5b Slider slider('destroy') throws excetion

Reported by: istvano Owned by: braeker
Priority: critical Milestone: 1.2.3
Component: ui Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

The following line throws an exception:

this.handles.removeMouseInteraction(); ( line 141 )

when I call the destroy method, stating thet this.handle has no properties.

I checked the object is null.

I tried the following ( removing the s at the end, as I can see there is a handle property not a handles one) .

although I do this, and then I re-create the slider, it just does not work, the min, max uses the old slider values, also the drag does not get initialized properly.

this.handle.removeMouseInteraction();

Change History (3)

comment:1 Changed 12 years ago by paul

Owner: changed from paul to braeker

comment:2 Changed 12 years ago by scott.gonzal

The re-creation problem is probably linked to #2496, which has been fixed.

comment:3 Changed 12 years ago by joern

Resolution: duplicate
Status: newclosed

Duplicate of #2496.

Note: See TracTickets for help on using tickets.