Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2479 closed bug (wontfix)

Interface/Sortables "containment" option breaks sorting

Reported by: dnl2ba Owned by: stefan
Priority: major Milestone: 1.2.4
Component: interface Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

When I enable the "containment: 'parent'" option and start dragging an item that starts at position x in a 1-indexed list of size n, I can't drop it at any position (x.. n-1]. I can drop it at position n (the end) and at position [0.. x]. So, the last and penultimate items are unaffected, but all others have the problem.

(Apologies in advance if I filed this incorrectly or if it's a dupe. I didn't find any relevant bugs with "sortables" and "containment.")

Attachments (1)

interfaceSortablesContainmentEnabled.zip (26.5 KB) - added by dnl2ba 12 years ago.
Example

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by dnl2ba

There's a bunch of noConflict/scoping wonkiness in the example (a holdover from my own application), but it's not relevant. I've tried taking it out and the bug is still evident.

Strict vs. quirks mode isn't relevant either.

I've reproduced the problem in Opera 9.50b, Firefox 3 beta 3, and IE7.

Changed 12 years ago by dnl2ba

Example

comment:2 Changed 12 years ago by dnl2ba

Er, and by "Interface/Sortables," I mean not UI/Sortables. I mean the library by Stefan Petre and Paul Bakaus: http://interface.eyecon.ro/docs/sort

comment:3 Changed 12 years ago by scott.gonzal

Resolution: wontfix
Status: newclosed

Interface is no longer supported; consider switching to jQuery UI.

Note: See TracTickets for help on using tickets.