Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2459 closed bug (invalid)

[value=something] seems to don't work

Reported by: Just Owned by:
Priority: major Milestone: 1.2.4
Component: core Version: 1.2.3
Keywords: selector value attribute Cc:
Blocked by: Blocking:

Description

with the HTML :

<li value="myValue">test OK!</li>

the Jquery syntax

$('li[value=test]').text();

return nothing! (the element "li" accept attribute "value" in "XHTML 1.1 transitional" which is the DTD I'm using)

But if I use the HTML

<li azheiu="myValue">test OK!</li>

[or other "strange" or "real" attribute than "azheiu"]

the Jquery syntax

$('li[azheiu=test]').text();

return "Test OK!".

Tested under FF and IE, so It don't seems to be a browser bug.

Change History (2)

comment:1 Changed 12 years ago by Just

Mouarf, It's [value=myValue] not [value=test] :/, and so [azheiu=myValue] not [azheiu=test]. Sorry.

comment:2 Changed 12 years ago by davidserduke

Resolution: invalid
Status: newclosed

I agree with Just that the test case has an error. If you can still reproduce the problem with a test case modified as Just suggests then please reopen this ticket with the new one.

Note: See TracTickets for help on using tickets.