Bug Tracker

Opened 12 years ago

Closed 11 years ago

#2414 closed bug (fixed)

Broken handling of embedded applets

Reported by: dimi Owned by:
Priority: major Milestone: 1.4
Component: event Version: 1.4a1
Keywords: Cc:
Blocked by: Blocking:

Description

When Java objects are present, the handling of ajax events break. The bug is at line 2019 in 1.2.3, and it generates the following exception:

Java class com.aurigma.imageuploader.ImageUploader has no public field or method named "onajaxStop"

Problem is at this line:

if ( !fn && elem["on"+type] && elem["on"+type].apply( elem, data ) === false ...

If we just try to access the "on"+type, the Java LiveConnect will try to lookup such a method on the Java object, and fail with an exception.

Change History (2)

comment:1 Changed 12 years ago by DanSwitzer2

This appears to be related to #2349 and #1675. The problem is that FF2 can't add handle the jQuery expando on any element that contains a Java applet.

comment:2 Changed 11 years ago by john

Component: coreevent
Milestone: 1.2.41.4
Resolution: fixed
Status: newclosed
Version: 1.2.31.4a1
Note: See TracTickets for help on using tickets.